Campus Cloud is currently inaccessible.

Incident Report for Ready Education

Resolved

This incident has been resolved.
Posted Aug 21, 2023 - 13:37 EDT

Monitoring

Campus Cloud access should be restored. You may observe slower loading times as content is reindexed for search.
Posted Aug 21, 2023 - 11:12 EDT

Identified

We are aware that Campus Cloud (campuscloud.readyeducation.com) is also affected by the current upgrade, and is currently inaccessible. We are working to resolve this immediately.
Posted Aug 21, 2023 - 10:12 EDT