The issue has been resolved. AWS has announced that it addressed the latency issues affecting a wide range of AWS services.
Posted Oct 29, 2025 - 10:38 EDT
Update
Services have stabilized and we aren't currently observing any issues. We will continue to monitor and provide updates if anything changes.
Posted Oct 28, 2025 - 17:23 EDT
Monitoring
We are currently investigating reports of intermittent errors and degraded performance across some of our applications.
This issue has been identified as stemming from resource availability constraints within the network of our primary cloud infrastructure provider, Amazon Web Services (AWS). This is a widespread issue affecting many services hosted on their platform.
Our engineering team is actively monitoring the situation with AWS support to track their progress toward a resolution. We understand the importance of reliable service and sincerely apologize for any disruption this may be causing.
We will provide further updates as they become available.